summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-08-13 03:09:14 +0300
committerDimitris Kiziridis2020-08-13 03:09:14 +0300
commit342a5343619bffbdb40c5faf04457950161f0174 (patch)
tree49b6ed983bface7325039822a016467dd591ebc3 /PKGBUILD
downloadaur-342a5343619bffbdb40c5faf04457950161f0174.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51aa269870d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=constellation
+pkgver=2.0.0
+pkgrel=1
+pkgdesc="A graph-focused data visualisation and interactive analysis application"
+arch=('x86_64')
+url='https://constellation-app.com'
+license=('Apache')
+depends=('java-runtime'
+ 'libnet'
+ 'lib32-glibc'
+ 'gtk3'
+ 'gtk2')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/constellation-app/constellation/releases/download/v${pkgver}/constellation-linux-v${pkgver}.tar.gz"
+ 'icon.png')
+sha256sums=('0ce920db6309b4418de4644aa21f4fa2ef7252ec828293f70b5fd6b10c24bb85'
+ 'SKIP')
+
+package() {
+ install -d "${pkgdir}/opt"
+ cp -avR constellation "${pkgdir}/opt"
+ install -Dm644 icon.png "${pkgdir}/usr/share/pixmaps/constellation.png"
+ gendesk -f -n --pkgname "${pkgname}" \
+ --pkgdesc "$pkgdesc" \
+ --name "Constellation" \
+ --comment "$pkgdesc" \
+ --exec "${pkgname}" \
+ --categories 'Utility;Development;Science;Application' \
+ --icon "${pkgname}"
+ install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications"
+ echo "#!/usr/bin/env bash
+ cd /opt/constellation/bin
+ ./constellation
+ " > "${pkgname}.sh"
+ install -Dm755 "${pkgname}.sh" "${pkgdir}/usr/bin/constellation"
+} \ No newline at end of file