summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkyechou2023-11-20 21:26:48 -0600
committerkyechou2023-11-20 21:26:48 -0600
commit485b346c6464847b270d6be5f03423302762d4d4 (patch)
tree60dab4f385ad1baaae50de74449c821433f6a902 /PKGBUILD
parent0a8b9afe6be77178bcdc4d2981d82707e36b9d48 (diff)
downloadaur-containernet-git.tar.gz
Fix strlcpy issue and update dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 148174943b18..8cc67dfab6d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,14 @@
# Contributor: Walter Dworak <preparationh67@gmail.com>
pkgname=containernet-git
-pkgver=3.1.r388.g541b268
+pkgver=3.1.r416.g31eeb75
pkgrel=1
pkgdesc="Mininet fork adding support for container-based emulated hosts"
_mn_deps=('python' 'iptables' 'iproute2' 'net-tools' 'iputils' 'inetutils'
'iperf' 'ethtool' 'libcgroup' 'openvswitch' 'psmisc')
-depends=(${_mn_deps[@]}
+depends=("${_mn_deps[@]}"
'docker' 'python-docker' 'python-pytest' 'python-iptables-git'
- 'python-pexpect' 'python-urllib3' 'python-networkx'
- 'python-ipaddress')
+ 'python-pexpect' 'python-urllib3' 'python-networkx')
optdepends=('xorg-xhost: for X11 forwarding'
'socat: for X11 forwarding'
'xterm: required for MiniEdit'
@@ -25,9 +24,11 @@ provides=('mininet')
conflicts=('mininet')
install="${pkgname%-git}.install"
source=("$pkgname"::'git+https://github.com/containernet/containernet'
- 'git+https://github.com/mininet/openflow')
+ 'git+https://github.com/mininet/openflow'
+ 'fix-openflow-strlcpy.patch')
sha256sums=('SKIP'
- 'SKIP')
+ 'SKIP'
+ '0a85f8a5ce2dd900d4f874849b28301aa47d7b9d7b03ed405c973d917d98383a')
pkgver() {
cd "$srcdir/$pkgname"
@@ -43,10 +44,13 @@ prepare() {
sed '/^include debian\/automake.mk/d' -i Makefile.am
# Patch controller to handle more than 16 switches
patch -Np1 -i "$srcdir/$pkgname/util/openflow-patches/controller.patch"
+ patch -Np1 -i "$srcdir/fix-openflow-strlcpy.patch"
cd "$srcdir/$pkgname"
- sed 's:PREFIX ?= /usr:PREFIX ?= "$(DESTDIR)"/usr:' -i Makefile
- sed '/^[[:space:]]*$(PYTHON) /d' -i Makefile
+ # shellcheck disable=SC2016
+ sed -i Makefile \
+ -e 's:PREFIX ?= /usr:PREFIX ?= "$(DESTDIR)"/usr:' \
+ -e '/^[[:space:]]*$(PYTHON) /d'
}
build() {