summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAditya Mahajan2015-02-05 14:49:50 -0500
committerAditya Mahajan2016-04-02 13:08:46 -0400
commit7f5016a42da147cd40b99a8aa5bf08daf6688bbc (patch)
treedb6da9c7ebb0ec9448d1b7ac3cd93c09c6bfaa9c /PKGBUILD
parent07ff618e35cac71f28e816af23f4ac74e6371351 (diff)
downloadaur-7f5016a42da147cd40b99a8aa5bf08daf6688bbc.tar.gz
Correctly set pkgver()
This package does not use git. We parse the pkgver from the \contextversion macro in context.mkiv
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bccc3a005c8..8171aedea2ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Aditya Mahajan <adityam at umich dot edu>
pkgname=context-minimals-git
-pkgver=20130615
+pkgver=2015.02.03
pkgrel=1
pkgdesc="A standalone ConTeXt distribution"
url="http://www.contextgarden.net"
@@ -47,6 +47,11 @@ _texlivefontdir="/usr/share/texmf-dist/fonts/"
_userfontdir="\$HOME/.fonts"
_osfontdir="/usr/share/fonts"
+pkgver() {
+ cd "$scrdir"
+ grep -e '\\edef\\contextversion' tex/texmf-context/tex/context/base/context.mkiv | sed -n 's/.*{\(.*\) .*}/\1/p'
+}
+
build() {
msg "Downloading the latest scripts first"
rsync -rlpt $_rsyncurl $srcdir || return 1