summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWilly Micieli2023-11-26 14:02:36 +0100
committerWilly Micieli2023-11-26 14:02:36 +0100
commitb73cb8ece1e2a1e547a16eaa20f84fc49f3ba05f (patch)
tree62437fc7f77a0d1ec7ed4ce4234f8905aeb90d7f /PKGBUILD
downloadaur-b73cb8ece1e2a1e547a16eaa20f84fc49f3ba05f.tar.gz
firt version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1fc049bba186
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Willy Micieli <micieli@vivaldi.net>
+
+pkgname=continuous-testing
+pkgver=0.3.4
+pkgrel=1
+pkgdesc="An rust program to test in continuous application"
+provides=("again")
+arch=('any')
+url="https://github.com/taishingi/continuous-testing"
+license=('GPL3')
+depends=('packer' 'docker' 'rust' 'git' 'wget' 'unzip')
+optdepends=('go: Go support')
+source=("${pkgver}.tar.gz::${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('9ce88d8980dacfb7cad4c272cdcbc5269f6f23cd3e5344c95390128812cadd63')
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ cargo install --path .
+}