summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormrxx2018-11-04 17:24:30 +0100
committermrxx2018-11-04 17:24:30 +0100
commiteb08d192f4b933c172027d919ac12f7593b78fdb (patch)
treef7e89976a9b951f543f7b670cbc8ab66fa09c10b /PKGBUILD
downloadaur-eb08d192f4b933c172027d919ac12f7593b78fdb.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c2d2a17864bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: mrxx <mrxx at cyberhome dot at>
+
+_debpkg=convert-pgn
+pkgname=convert-pgn-bin
+pkgver=0.29.6
+pkgrel=1
+pkgdesc="Convert format of given chess book from one format to PGN, the Portable Game Notation format."
+arch=('i686' 'x86_64')
+url="http://www.xqbase.com/"
+license=('GPL2')
+conflicts=('convert-pgn' 'gmchess')
+makedepends=('libarchive')
+source_i686=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_i386.deb")
+source_x86_64=("http://security.ubuntu.com/ubuntu/pool/universe/g/gmchess/${_debpkg}_${pkgver}-3_amd64.deb")
+sha1sums_i686=('0d62fc8172f29df247eea8deb2bdeb6f998535c8')
+sha1sums_x86_64=('046bbb093981171729f67bb1540fe903f0bd48a2')
+
+prepare() {
+ bsdtar xf data.tar.xz
+}
+
+package(){
+ install -d $pkgdir/usr/{bin,share}
+ install -Dm755 $srcdir/usr/bin/convert_pgn $pkgdir/usr/bin/
+ cp -r "$srcdir/usr/share" "$pkgdir/usr/"
+}