summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorVlad Vasiliu2022-10-26 12:53:23 +0200
committerVlad Vasiliu2022-10-26 12:53:23 +0200
commit119d51f45f42f7c38c620b63665fe2f6a504bbee (patch)
treeb98bbf5c4b622e978065124aaee9cdae487bf500 /PKGBUILD
parent86c29f679e707643cf3ca0210c738348bfb679a3 (diff)
downloadaur-119d51f45f42f7c38c620b63665fe2f6a504bbee.tar.gz
Create completions directories before generating completions
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57bab9b26fe3..1a2ed7889016 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Vlad Vasiliu <vladvasiliun@yahoo.fr>
pkgname=copilot-cli-bin
pkgver=1.22.1
-pkgrel=2
+pkgrel=3
pkgdesc='Your toolkit for containerized applications on AWS.'
arch=('aarch64' 'x86_64')
url='https://aws.github.io/copilot-cli/'
@@ -18,6 +18,9 @@ noextract=("copilot-${pkgver}")
package() {
install -Dm 755 ${srcdir}/copilot-${pkgver} ${pkgdir}/usr/bin/copilot
+
+ install -dm 755 "$pkgdir/usr/share/bash-completion/completions"
+ install -dm 755 "$pkgdir/usr/share/zsh/site-functions"
"$pkgdir/usr/bin/copilot" completion bash > "$pkgdir/usr/share/bash-completion/completions/copilot"
"$pkgdir/usr/bin/copilot" completion zsh > "$pkgdir/usr/share/zsh/site-functions/_copilot"
}