summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2021-02-12 20:26:39 +0000
committerDaniel Bermond2021-02-12 20:26:39 +0000
commit422ae66b73fd53c769e67244218c54cb09901103 (patch)
tree2482f568567e1a3d8c69f5133a269535b1f34215 /PKGBUILD
parentf121955a513b44b3700bcdb1565d6327ea459e0c (diff)
downloadaur-422ae66b73fd53c769e67244218c54cb09901103.tar.gz
Fix conflicts with repository qt packages
Package is now co-installable with qt5-base, qt5-tools and qt6-base. Note: was previously missing conflicts with qt5-base and qt6-base.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72ed8789fa6b..16c4016edec4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=copperspice
pkgver=1.7.1
-pkgrel=1
+pkgrel=2
pkgdesc='Libraries for developing cross platform software applications in C++'
arch=('x86_64')
url='https://www.copperspice.com/'
@@ -16,13 +16,20 @@ optdepends=('mariadb-libs: for MySQL database support'
makedepends=('cmake' 'alsa-lib' 'mariadb-libs' 'postgresql' 'postgresql-libs'
'libxcursor' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr'
'libxrender' 'libxml2')
-conflicts=('qt5-tools')
-source=("https://github.com/copperspice/copperspice/archive/cs-${pkgver}/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('2e74c809f6e9bffbe53f2f758b280781f6905631d9647717b47bc9202dba0d41')
+source=("https://github.com/copperspice/copperspice/archive/cs-${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ '010-copperspice-fix-cmake-include-dirs.patch')
+sha256sums=('2e74c809f6e9bffbe53f2f758b280781f6905631d9647717b47bc9202dba0d41'
+ '14c52854ed1d92430a4b4ce6dd967f86141cc3352784b2396f786575bac0bdd0')
+
+prepare() {
+ patch -d "copperspice-cs-${pkgver}" -Np1 -i "${srcdir}/010-copperspice-fix-cmake-include-dirs.patch"
+}
build() {
cmake -B build -S "copperspice-cs-${pkgver}" \
-DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_BINDIR:PATH='lib/copperspice/bin' \
+ -DCMAKE_INSTALL_INCLUDEDIR:PATH='include/copperspice' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
-Wno-dev
make -C build
@@ -30,4 +37,11 @@ build() {
package() {
make -C build DESTDIR="$pkgdir" install
+
+ local _file
+ mkdir -p "${pkgdir}/usr/bin"
+ while read -r -d '' _file
+ do
+ ln -s "../lib/copperspice/bin/${_file##*/}" "${pkgdir}/usr/bin/${_file##*/}-cs"
+ done < <(find "${pkgdir}/usr/lib/copperspice/bin" -type f -executable -print0)
}