summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Bermond2022-09-23 18:10:50 -0300
committerDaniel Bermond2022-09-23 18:10:50 -0300
commita2cf52c8b01ddbd1fec2e77b0368b71fb4732cb8 (patch)
tree590099c84a77a3966cd85f5dd22eadac56450c4e /PKGBUILD
parent70bfa8ff1af05f293b57f231148f0dbdc46d0b3b (diff)
downloadaur-a2cf52c8b01ddbd1fec2e77b0368b71fb4732cb8.tar.gz
Update to version 1.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c4ac7a0ddf0..9b46be9cc5b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=copperspice
-pkgver=1.7.4
+pkgver=1.8.0
pkgrel=1
pkgdesc='Libraries for developing cross platform software applications in C++'
arch=('x86_64')
@@ -9,18 +9,18 @@ url='https://www.copperspice.com/'
license=('LGPL2.1')
depends=('cups' 'fontconfig' 'glib2' 'gstreamer' 'gst-plugins-base-libs' 'libgl'
'libice' 'libpulse' 'libsm' 'libx11' 'libxcb' 'libxi' 'libxkbcommon'
- 'libxkbcommon-x11' 'openssl' 'xcb-util-keysyms' 'xcb-util-image'
- 'xcb-util-renderutil' 'xcb-util-wm' 'zlib')
+ 'libxkbcommon-x11' 'openssl' 'vulkan-icd-loader' 'xcb-util-keysyms'
+ 'xcb-util-image' 'xcb-util-renderutil' 'xcb-util-wm' 'zlib')
optdepends=('mariadb-libs: for MySQL database support'
'postgresql-libs: for PostgreSQL database support')
makedepends=('cmake' 'alsa-lib' 'mariadb-libs' 'postgresql' 'postgresql-libs'
- 'libxcursor' 'libxext' 'libxfixes' 'libxinerama' 'libxrandr'
- 'libxrender' 'libxml2')
+ 'vulkan-headers' 'libxcursor' 'libxext' 'libxfixes' 'libxinerama'
+ 'libxrandr' 'libxrender' 'libxml2')
options=('!lto')
source=("https://github.com/copperspice/copperspice/archive/cs-${pkgver}/${pkgname}-${pkgver}.tar.gz"
'010-copperspice-fix-cmake-include-dirs.patch')
-sha256sums=('3619285fff80d9f0f7cfcc2e2d3229045a3354af4c1274650bf11257a3b53cdd'
- 'ad8764d825950dcb98a1088a2f778d449c39e33a3c2edf037a45c30c341045d4')
+sha256sums=('33eecd475f77b347343806e94d80efc68523acae3d382fba4a29b36a1d0cc505'
+ 'f383d50fe4b3a6ba428dbc1a4822173aff1bd2ba57efb31c8bd977f75db5c3e8')
prepare() {
patch -d "copperspice-cs-${pkgver}" -Np1 -i "${srcdir}/010-copperspice-fix-cmake-include-dirs.patch"