summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Schramm2019-04-02 15:33:53 +0200
committerMarcel Schramm2019-04-02 15:33:53 +0200
commitd9dc7bcb570334a33a86b622633784f64ef7ae2a (patch)
tree6c2a9fa1148fd26b57f79a81d0cf6f54a8e42d26 /PKGBUILD
downloadaur-d9dc7bcb570334a33a86b622633784f64ef7ae2a.tar.gz
Initial commit of package for cordless
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2a0176035b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Marcel Schramm <marcelschr@protonmail.com>
+
+pkgname=cordless-git
+pkgver=2019.03.26
+pkgrel=1
+pkgdesc='A Discord TUI client.'
+arch=('x86_64')
+url="https://github.com/Bios-Marcel/cordless"
+license=('BSD-3')
+source=("$pkgname::git+https://github.com/Bios-Marcel/cordless.git")
+depends=('glibc')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --abbrev=0 | sed 's/-/./g'
+}
+
+build() {
+ cd "$pkgname"
+ go build \
+ -gcflags "all=-trimpath=$PWD" \
+ -asmflags "all=-trimpath=$PWD" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
+
+package() {
+ cd $pkgname
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/cordless
+}