summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTom Wambold2020-05-13 09:43:56 -0400
committerTom Wambold2020-05-13 09:43:56 -0400
commitecdbb398c1ff51e98bc790e0ef608041b45aa3ea (patch)
treef31c301e0f6a80007e8bb60273061906f0fdf1b6 /PKGBUILD
parentf58b09c7b3940f4e6e5f8f2f7c34315649172954 (diff)
downloadaur-ecdbb398c1ff51e98bc790e0ef608041b45aa3ea.tar.gz
Update to CORE 6.4.0 release.
* Disable Sphinx documentation, failed to build without custom theme package. * Remove python-sphinx dependency.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 566fed9599e6..6ee97087bf0e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Tom Wambold <tom5760@gmail.com>
pkgname=core
-pkgver=6.3.0
+pkgver=6.4.0
pkgrel=1
pkgdesc="Common Open Research Emulator"
arch=('i686' 'x86_64')
@@ -10,12 +10,11 @@ depends=('bridge-utils' 'ebtables' 'ethtool' 'fabric' 'iproute2' 'libev'
'openvswitch' 'procps-ng' 'python3' 'python-future' 'python-grpcio'
'python-lxml' 'python-mako' 'python-netaddr' 'python-pillow' 'python-pyproj'
'python-yaml' 'tkimg' 'util-linux' 'xterm')
-makedepends=('help2man' 'imagemagick' 'python-sphinx' 'python-grpcio-tools'
- 'openvswitch')
+makedepends=('help2man' 'imagemagick' 'python-grpcio-tools' 'openvswitch')
optdepends=('openvswitch: Open vSwitch support')
backup=('etc/core/core.conf')
source=("https://github.com/coreemu/core/archive/release-$pkgver.tar.gz")
-md5sums=('a20e285e77cc4282a503595181ab305d')
+md5sums=('e3af7375a50547b7e7700095d829daf3')
build() {
cd "$srcdir/core-release-$pkgver"
@@ -23,8 +22,7 @@ build() {
./bootstrap.sh
./configure \
--prefix=/usr \
- --with-startup=systemd \
- --enable-docs
+ --with-startup=systemd
make
}