summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeonidas Spyropoulos2021-06-25 11:16:56 +0100
committerLeonidas Spyropoulos2021-06-25 11:16:56 +0100
commit8bee103b0d79146b697dc4cf1d42e3b360779591 (patch)
treea76e27005679fa8a47c215f00ae9ebc95deb9a3d /PKGBUILD
parentdedf37b0f04df5533fc7107ea52437a010977916 (diff)
downloadaur-8bee103b0d79146b697dc4cf1d42e3b360779591.tar.gz
Add makeflag for Transparency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a6dc94408c64..3db076e9b81b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,14 @@
# Maintainer: Leonidas Spyropoulos <artafinde at gmail dot com>
# Contributor: CyrIng <labs[at]cyring[dot]fr>
+### BUILD OPTIONS
+# Set the next variables to ANYTHING that is not null to enable them
+
+# Enable transparency mode in terminal
+_transparency=
+
+### Do no edit below this line unless you know what you're doing
+
pkgbase=corefreq
pkgname=(corefreq-client corefreq-server corefreq-dkms)
_gitname=CoreFreq
@@ -18,7 +26,11 @@ b2sums=('fa861cbf607a628eb769391986923a1a120ac4e2ca036279043303f7bfe429c0b92bf42
build() {
cd "${_gitname}-${pkgver}"
- make corefreqd corefreq-cli
+ if [ -n "${_transparency}" ]; then
+ make corefreqd corefreq-cli UI_TRANSPARENCY=1
+ else
+ make corefreqd corefreq-cli
+ fi
}
package_corefreq-dkms() {