summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlibrewish2020-01-24 23:34:05 +0530
committerlibrewish2020-01-24 23:34:05 +0530
commit5391e78e7323b2013d16f7d3b303796b3b1c7efb (patch)
tree457bc42a7859453542b7297153418fccf8074559 /PKGBUILD
downloadaur-5391e78e7323b2013d16f7d3b303796b3b1c7efb.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf144d05b178
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=corepdf
+pkgname=${_pkgname}-git
+pkgver=v2.8.0.r0.8d3a8b7
+pkgrel=1
+pkgdesc="A PDF viwer from the CoreApps family."
+arch=('i686' 'x86_64')
+url="https://gitlab.com/cubocore"
+license=('GPL3')
+depends=('libcprime-git' 'poppler-qt5')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('coreapps-git')
+source=("git+https://gitlab.com/cubocore/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}