summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Johansen2025-01-18 09:56:08 +0100
committerDan Johansen2025-01-18 09:56:08 +0100
commit2dafefbfc8a02cfb581af95e9f9267844595c9e6 (patch)
tree3ee779735e3c0f7eecf90a997c34c334aa7cdd5c /PKGBUILD
parent9be21f649e23f4c28e7fc8ab6d868ca16b449e14 (diff)
downloadaur-2dafefbfc8a02cfb581af95e9f9267844595c9e6.tar.gz
Adjust PKGBUILD to meet more packaging standards
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 14 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9afbfe8cb7b8..568c53d48f68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,25 @@
pkgname=coreshot
pkgver=4.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A screen capture utility from the C Suite"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/coreapps/$pkgname"
-license=('GPL3')
-depends=('qt5-base' 'qt5-x11extras' 'libcprime>=2.7.1')
-makedepends=('cmake' 'ninja')
+license=('GPL-3.0-or-later')
+depends=(
+ 'qt5-base'
+ 'qt5-x11extras'
+ 'hicolor-icon-theme'
+ 'libx11'
+ 'libcprime>=2.7.1'
+)
+makedepends=(
+ 'cmake'
+ 'ninja'
+)
groups=('coreapps')
source=("https://gitlab.com/cubocore/coreapps/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-md5sums=('0d3eadb08c489fbeb4d97c4b5a1a4c3a')
+sha256sums=('b8be153e3467d2ddc4d4270605dbd1cc9f86a1b551cf36c1b5ee5c53b8bec9dd')
prepare() {
mkdir -p build