summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Johansen2021-04-21 09:57:31 +0200
committerDan Johansen2021-04-21 09:57:31 +0200
commit484e72698febf007be7205a5a5ae4d4fe1b68c21 (patch)
treec2e49398cfd53d840a8f38bacc907803a05eefc1 /PKGBUILD
parent3c7ac776b91c50f177f04d2ba9cce619e0fc77c4 (diff)
downloadaur-484e72698febf007be7205a5a5ae4d4fe1b68c21.tar.gz
Fix PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3053a565ef33..b44d720f8fd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,14 @@
pkgname=corestuff
pkgver=4.2.0
-pkgrel=1
-pkgdesc="An activity viewer from the CoreApps family."
+pkgrel=2
+pkgdesc="An activity viewer from the C Suite"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/cubocore/coreapps/$pkgname"
license=('GPL3')
depends=('qt5-base' 'qt5-x11extras' 'libxcomposite' 'kglobalaccel' 'libcsys>=2.7.1' 'libcprime>=2.7.1')
makedepends=('cmake' 'ninja')
replaces=('corebox')
-groups=('coreapps')
source=("https://gitlab.com/cubocore/coreapps/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
md5sums=('728ee1f869955c3bd25811d89b2bfb12')
@@ -23,12 +22,12 @@ build() {
cd build
cmake ../${pkgname}-v${pkgver} \
-GNinja \
- -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr \
- -DCMAKE_INSTALL_LIBDIR=${pkgdir}/usr/lib
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
ninja
}
package() {
cd build
- ninja install
+ DESTDIR="${pkgdir}" ninja install
}