summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDan Johansen2019-09-16 15:26:12 +0200
committerDan Johansen2019-09-16 15:26:12 +0200
commit75add3264b3982f7066c1f26edb73fcdf1711fda (patch)
tree06402bf11fc5458213a1a50199e2ba16e6256c00 /PKGBUILD
downloadaur-75add3264b3982f7066c1f26edb73fcdf1711fda.tar.gz
initial commit, version 2.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..30a44e386b7c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Contributor: Shaber
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+pkgname=coreterminal
+pkgver=2.7.0
+pkgrel=1
+pkgdesc="A terminal emulator from the CoreApps family."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/cubocore/$pkgname"
+license=('GPL3')
+depends=('qt5-base' 'libcprime' 'qtermwidget')
+groups=('coreapps')
+source=("https://gitlab.com/cubocore/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+md5sums=('3da763ece77698dac7d4fcfbd8b63a95')
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd ${pkgname}-v${pkgver}
+
+ qmake-qt5 ${pkgname}.pro
+ make
+}
+
+package() {
+ cd ${pkgname}-v${pkgver}
+ make INSTALL_ROOT=${pkgdir} install
+}