summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2015-05-30 10:10:03 +0800
committerNicolas Iooss2015-06-27 12:01:20 +0800
commit1da3c44ea99118f42346e82be25fc89dc5755301 (patch)
treed3bda83ffcb8f336baa86ea22823e354580b679d /PKGBUILD
parent2873fda6abe22fef37916ffe22b6b4beb551616c (diff)
downloadaur-1da3c44ea99118f42346e82be25fc89dc5755301.tar.gz
coreutils-selinux 8.23-3 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 23 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 98dc6125d9ee..413e5c7803bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# $Id$
-# Maintainer: Sébastien "Seblu" Luttringer
-# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Maintainer: Sébastien "Seblu" Luttringer
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>
# SELinux Maintainer: Nicolas Iooss (nicolas <dot> iooss <at> m4x <dot> org)
@@ -9,29 +9,36 @@
pkgname=coreutils-selinux
pkgver=8.23
-pkgrel=2
-pkgdesc="The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support"
+pkgrel=3
+pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support'
arch=('i686' 'x86_64')
license=('GPL3')
-url="http://www.gnu.org/software/coreutils"
+url='http://www.gnu.org/software/coreutils'
groups=('selinux')
-depends=('glibc' 'pam-selinux' 'acl' 'gmp' 'libcap' 'openssl' 'libselinux')
+depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl' 'libselinux')
install=${pkgname/-selinux}.install
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9')
-source=("ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig})
+source=("ftp://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig}
+ '01-btrfs-alloc.patch')
+validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
md5sums=('abed135279f87ad6762ce57ff6d89c41'
- 'SKIP')
+ 'SKIP'
+ '7333cea9afddff017dd0445fc5b8cc8f')
-#prepare() {
-# cd $pkgname-$pkgver
-#}
+prepare() {
+ local _p
+ for _p in *.patch; do
+ [[ -e $_p ]] || continue
+ msg2 "Applying $_p"
+ patch -p1 -d ${pkgname/-selinux}-$pkgver < "$_p"
+ done
+}
build() {
cd ${pkgname/-selinux}-$pkgver
- ./configure \
+ ./configure \
--prefix=/usr \
--libexecdir=/usr/lib \
--with-openssl \
@@ -42,10 +49,12 @@ build() {
check() {
cd ${pkgname/-selinux}-$pkgver
- make RUN_EXPENSIVE_TESTS=yes check
+ RUN_VERY_EXPENSIVE_TESTS=yes make check
}
package() {
cd ${pkgname/-selinux}-$pkgver
make DESTDIR="$pkgdir" install
}
+
+# vim:set ts=2 sw=2 et: