summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicolas Iooss2023-04-09 16:53:51 +0200
committerNicolas Iooss2023-04-09 16:53:51 +0200
commitdb894d027f76444a0de93aac2e9449b9f304b1ac (patch)
tree20c8fa7ec78065fd64a6608b0fc3e75518c0fff7 /PKGBUILD
parentcab7bfddf62073cccc0553afff56b25c46dad3f2 (diff)
downloadaur-db894d027f76444a0de93aac2e9449b9f304b1ac.tar.gz
coreutils-selinux 9.2-3 update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 907308cc7496..8a4474c92782 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
pkgname=coreutils-selinux
pkgver=9.2
-pkgrel=1
+pkgrel=3
pkgdesc='The basic file, shell and text manipulation utilities of the GNU operating system with SELinux support'
arch=('x86_64' 'aarch64')
license=('GPL3')
@@ -21,22 +21,30 @@ depends=('glibc' 'acl' 'attr' 'gmp' 'libcap' 'openssl' 'libselinux')
conflicts=("${pkgname/-selinux}" "selinux-${pkgname/-selinux}")
provides=("${pkgname/-selinux}=${pkgver}-${pkgrel}"
"selinux-${pkgname/-selinux}=${pkgver}-${pkgrel}")
-source=("https://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig})
+source=("https://ftp.gnu.org/gnu/${pkgname/-selinux}/${pkgname/-selinux}-$pkgver.tar.xz"{,.sig}
+ '01-FS#77969.patch::https://git.savannah.gnu.org/cgit/coreutils.git/patch/?id=76f2fb627118a26c25003dbd98c22c153b7ee1d2'
+ 'copy-fix-reflink-auto-fallback.patch'
+ 'gnulib-backupfile-62607.patch'
+ 'coreutils-backup-62607.patch')
validpgpkeys=('6C37DC12121A5006BC1DB804DF6FD971306037D9') # Pádraig Brady
sha256sums=('6885ff47b9cdb211de47d368c17853f406daaf98b148aaecdf10de29cc04b0b3'
- 'SKIP')
+ 'SKIP'
+ 'a3cc5d1548bd6a26e1b8f4cff076862243af9faaffc4c257a0c766457fd028cc'
+ '4b2ac873a9cb4a825bb90e964383ca0cb956ece347e9ded5387ddd8ff293855b'
+ '5455ce8f736d5d8f5c7a5c8b70b4ec46a7e050125924f2135af4fbf685bddda6'
+ '10a8ea0b14c5254775c3817a31a07928c0609ca3eaec78fcecddeefe95101b9d')
prepare() {
cd ${pkgname/-selinux}-$pkgver
# apply patch from the source array (should be a pacman feature)
- local filename
- for filename in "${source[@]}"; do
- if [[ "$filename" =~ \.patch$ ]]; then
- echo "Applying patch ${filename##*/}"
- patch -p1 -N -i "$srcdir/${filename##*/}"
- fi
+ local src
+ for src in "${source[@]}"; do
+ src="${src%%::*}"
+ src="${src##*/}"
+ [[ $src = *.patch ]] || continue
+ echo "Applying patch $src..."
+ patch -Np1 < "../$src"
done
- :
# tail -F fails to find out that files are removed, in test VM
# so disable the tests which verify this