summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorIan D. Scott2015-06-18 09:57:28 -0700
committerIan D. Scott2015-06-18 09:57:28 -0700
commit8d043d769a147d1058b1c6bd08fce58ae27d6d44 (patch)
tree349e9b07513c1559f7a4550fe3a5b32b189bb584 /PKGBUILD
downloadaur-8d043d769a147d1058b1c6bd08fce58ae27d6d44.tar.gz
Initial import into git
Not using version from old repo, because the aur4 did not accept the large patch file. It therefore downloads the patch instead of including it.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..39de1cdae883
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Ian D. Scott <ian@perebruin.com>
+# Maintainer: kfgz <kfgz at interia dot pl>
+# Contributor: damir <damir at archlinux dot org>
+
+_pkgname=corewars
+pkgname=corewars-gtk2
+pkgver=0.9.13
+pkgrel=1
+pkgdesc="Simulation game where a number of programs try to crash each other"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/corewars/"
+license=('GPL2')
+depends=('gtk2')
+source=(${_pkgname}-${pkgver}.tar.gz::http://sourceforge.net/projects/${_pkgname}/files/${_pkgname}%20%28stable%2C%20tar.gz%29/${pkgver}/${_pkgname}-${pkgver}.tar.gz/download http://sourceforge.net/p/corewars/patches/_discuss/thread/947a192c/b4cd/attachment/corewars-gtk2.patch.gz)
+md5sums=('0a0b8067533b83a96488109ee265f664'
+ '557e1601a94f76862014c271b4e06d8f')
+
+prepare() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ zcat ../corewars-gtk2.patch.gz | patch -p1
+ sed -i 's/LIBS="$LIBS $GTK_LIBS"/LIBS="-lm $LIBS $GTK_LIBS"/' configure.ac
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}