aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStefan Göbel2017-03-31 02:26:41 +0200
committerStefan Göbel2017-03-31 02:26:41 +0200
commit17756534b4c7a014669726da9b98056baef9a172 (patch)
treed3be02a1c32eb6473ecbc022e38f70b88d176c3a /PKGBUILD
downloadaur-17756534b4c7a014669726da9b98056baef9a172.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..16e0db55b5ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Stefan Göbel <aur —at— subtype —dot— de>
+
+pkgname='corky'
+pkgver='2017033001'
+pkgrel='1'
+pkgdesc='Some Lua modules for the system monitor Conky.'
+url='https://gitlab.com/goeb/corky/'
+install="$pkgname.install"
+arch=('any')
+license=('GPL3')
+depends=('conky-cairo' 'lua-lpeg')
+source=("$pkgname::git+https://gitlab.com/goeb/$pkgname.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+
+ cd "$pkgname"
+
+ # Change the modules path in the example:
+ sed -i 's!"lua/corky.lua"!"/usr/share/lua/5.3/corky.lua"!' 'example/conky.conf'
+
+}
+
+package() {
+
+ cd "$pkgname"
+
+ # Install the modules:
+ install -dm 0755 "${pkgdir}/usr/share/lua/5.3"
+ cp -a lua/* "${pkgdir}/usr/share/lua/5.3"
+
+ # Install the README file and the example:
+ install -dm 0755 "${pkgdir}/usr/share/doc/corky"
+ cp -a README "${pkgdir}/usr/share/doc/corky"
+ cp -a example "${pkgdir}/usr/share/doc/corky"
+
+}
+
+#:indentSize=3:tabSize=3:noTabs=true:mode=shellscript:maxLineLen=87: \ No newline at end of file