summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorClay Stan2021-03-18 15:48:50 +0800
committerClay Stan2021-03-18 15:48:50 +0800
commit653d02eed3fc5a65772e271e247eb7e6b4726cbe (patch)
tree33dba3df914fa035073484df453429663eb70e2b /PKGBUILD
downloadaur-653d02eed3fc5a65772e271e247eb7e6b4726cbe.tar.gz
New upstream version 1.0.6
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05af28ce52a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Clay Stan <claystan97@gmail.com>
+pkgname=cornus
+pkgver=1.0.6
+pkgrel=1
+pkgdesc="A fast file browser for Linux"
+arch=('any')
+url="https://github.com/f35f22fan/Cornus"
+license=('GPL3')
+depends=('qt5-base' 'dconf' 'udisks2')
+makedepends=('cmake')
+optdepends=('ark')
+source=("https://github.com/f35f22fan/Cornus/archive/v1.0.6.tar.gz")
+md5sums=('83fb04ff43b6a175fdcd8e8dca259783')
+validpgpkeys=("4588 CB58 CB89 35FA C7DD 02D0 23C0 FC60 B040 BEC3")
+_pkgName=Cornus
+
+build() {
+ cd "$_pkgName-$pkgver"
+ mkdir build
+ cd build
+ cmake ../
+ make -j8
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/cornus/
+ cp -r "$_pkgName-$pkgver"/file_icons/ ${pkgdir}/usr/share/cornus/
+ install -Dm644 "$_pkgName-$pkgver"/export/cornus_mas.desktop ${pkgdir}/usr/share/applications/cornus.desktop
+ install -Dm644 "$_pkgName-$pkgver"/resources/cornus.mas.png ${pkgdir}/usr/share/icons/hicolor/128x128/apps/cornus.mas.png
+ install -D "$_pkgName-$pkgver"/build/cornus ${pkgdir}/usr/bin/cornus
+ install "$_pkgName-$pkgver"/build/cornus_io ${pkgdir}/usr/bin/cornus_io
+}