summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLeo Lahtinen2020-03-21 21:12:22 +0200
committerLeo Lahtinen2020-03-21 21:12:22 +0200
commit0ec0f5c35cf767fa91a82af8835e7c4de18a0675 (patch)
tree14050ea0cdeafceea62b5b970ed48858a24ec965 /PKGBUILD
downloadaur-coronavirus-tracker-cli.tar.gz
added to aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b071cc72e26a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Leo_L <Leo dot Lahtinen at protonmail dot com>
+pkgname=coronavirus-tracker-cli
+pkgver=0.7.0
+pkgrel=1
+pkgdesc="Track The Coronavirus from your CLI"
+url="https://github.com/sagarkarira/coronavirus-tracker-cli/"
+license=('WTFPL')
+arch=(any)
+depends=('nodejs')
+makedepends=('npm' 'jq')
+source=(http://registry.npmjs.org/$pkgname/-/$pkgname-$pkgver.tgz)
+md5sums=('b14675f03c5405d8dec816bc11917061')
+
+package() {
+ npm install -g --user root --cache "${srcdir}/npm-cache" --prefix "$pkgdir"/usr "$srcdir"/$pkgname-$pkgver.tgz
+
+ # Non-deterministic race in npm gives 777 permissions to random directories.
+ # See https://github.com/npm/npm/issues/9359 for details.
+ find "${pkgdir}"/usr -type d -exec chmod 755 {} +
+
+ # Remove references to pkgdir
+ find "$pkgdir" -type f -name package.json -print0 | xargs -0 sed -i "/_where/d"
+
+ # Remove references to srcdir
+ local tmppackage="$(mktemp)"
+ local pkgjson="$pkgdir/usr/lib/node_modules/$pkgname/package.json"
+ jq '.|=with_entries(select(.key|test("_.+")|not))' "$pkgjson" > "$tmppackage"
+ mv "$tmppackage" "$pkgjson"
+ chmod 644 "$pkgjson"
+
+ # npm gives ownership of ALL FILES to build user
+ # https://bugs.archlinux.org/task/63396
+ chown -R root:root "$pkgdir"
+}