summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2024-05-09 13:05:42 -0600
committerMark Wagie2024-05-09 13:05:42 -0600
commit171ca06c804e7506388dd50f893829f813f1d1ce (patch)
tree825aad3f12e0cfd4f1b9b5010e7b6bd0ac928334 /PKGBUILD
parent926a82d6833420b7510f11fdd5304300d437401b (diff)
downloadaur-171ca06c804e7506388dd50f893829f813f1d1ce.tar.gz
use mold linker
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2abcf8931a61..70fb8eb79b71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,6 +14,7 @@ depends=(
makedepends=(
'cargo'
'git'
+ 'mold'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -38,7 +39,12 @@ build() {
cd "${pkgname%-git}"
export CARGO_HOME="$srcdir/cargo-home"
export RUSTUP_TOOLCHAIN=stable
- make prefix='/usr' VENDOR='1' all
+
+ # use mold instead of lld to speed up build
+ RUSTFLAGS="-C link-arg=-fuse-ld=mold"
+
+ # use nice to build with lower priority
+ nice make prefix='/usr' VENDOR='1' all
}
package() {