summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlad Wenter2015-07-25 00:45:01 +0200
committerAlad Wenter2015-07-25 00:45:01 +0200
commitf2e0fa32508af89497f61fc18578d4826626d7a2 (patch)
tree3ca074e4c9813a36c1b206ce04aaa3856015198a /PKGBUILD
parent8d96720ed84179a2c54c8c3b397f23aaedc1b90d (diff)
downloadaur-f2e0fa32508af89497f61fc18578d4826626d7a2.tar.gz
upd
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8160ed7b8c38..db9ce5fcc2dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,39 @@
# Maintainer: Alad Wenter <https://wiki.archlinux.org/index.php/Special:EmailUser/Alad>
pkgname=cottage-git
-_pkgname=cottage
pkgver=94f2379
pkgrel=4
pkgdesc="Use howm commands, operators and set configuration values through a UNIX socket."
-arch=('i686' 'x86_64')
url="https://github.com/HarveyHunt/cottage"
license=('GPL')
+arch=('i686' 'x86_64')
checkdepends=('linux-headers')
-options=('!strip' 'debug')
-source=("git+https://github.com/HarveyHunt/cottage#branch=master")
+options=('debug')
+source=("$pkgname::git+https://github.com/HarveyHunt/cottage#branch=master")
sha256sums=('SKIP')
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
git rev-parse --short HEAD
}
build() {
- cd "$_pkgname"
+ cd "$pkgname"
make debug
}
check() {
- cd "$_pkgname"
+ cd "$pkgname"
find /usr/lib/modules -name checkpatch.pl -print -quit | xargs -i cp {} .
- echo "spellingtxt||getoutofmyface" > spelling.txt
+ printf 'spellingtxt||disable\n' > spelling.txt
make check
}
package() {
- cd "$_pkgname"
+ cd "$pkgname"
install -Dm755 "bin/debug/cottage" "$pkgdir/usr/bin/cottage"
}