summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorwillemw122021-01-16 12:09:27 +0100
committerwillemw122021-01-16 12:09:27 +0100
commit10b232f94085e9231cdbeb78c2aa528a7998fc15 (patch)
treeed0cbe9e0d95c9ace404e25836a5ce302cb5296a /PKGBUILD
parent5f306d875f27b3b493cafb6d30b8425cef6d7985 (diff)
downloadaur-10b232f94085e9231cdbeb78c2aa528a7998fc15.tar.gz
Change from "GIT" install to "source" install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 53edca27eefc..8663b56ad486 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,9 @@ pkgdesc="Automatic Movie Downloading via NZBs & Torrents"
arch=('any')
url="http://couchpota.to/"
license=('GPL3')
+makedepends=('git')
# 'python2-pyopenssl' is deprecated
-depends=('git' 'python2-lxml')
+depends=('python2-lxml')
#depends=('python2-lxml')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -41,11 +42,8 @@ package() {
cd $pkgname
- # A "GIT" install includes the .git folder
+ # A "source" install does not include the .git folder
install 755 -d "$pkgdir/opt/couchpotato/app"
- cp -a . "$pkgdir/opt/couchpotato/app"
-
- git -C "$pkgdir/opt/couchpotato/app" remote set-url origin $_giturl
- git -C "$pkgdir/opt/couchpotato/app" switch develop # master
+ cp -a * "$pkgdir/opt/couchpotato/app"
}