summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Ruijl2016-05-05 11:41:02 +0200
committerBen Ruijl2016-05-05 11:41:02 +0200
commit3f2e4c483a84333e5eb56941e774410a26febfe3 (patch)
treeb74d82960348e8ab0b1a5eb9be3b5c9f4dfec8e1 /PKGBUILD
parentf7c0ddce362e1ffbddedb3be9376e2b813872f78 (diff)
downloadaur-3f2e4c483a84333e5eb56941e774410a26febfe3.tar.gz
Several fixes
- env python is replaced by env python2 - No more forking for systemd process - Added provides and conflicts
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 15ed5e03ea95..dc9979c85043 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=couchpotato-git
_gitname=CouchPotatoServer
-pkgver=2054.fc8db13
+pkgver=4869.c4fad95
pkgrel=1
pkgdesc="Automatic Movie Downloading via NZBs & Torrent"
arch=('any')
@@ -10,9 +10,11 @@ url="http://couchpota.to/"
license=('GPL3')
depends=('python2')
makedepends=('git')
+provides=('couchpotato')
+conflicts=('couchpotato')
install='couchpotato.install'
source=('git://github.com/RuudBurger/CouchPotatoServer.git' 'couchpotato.service')
-md5sums=('SKIP' '82813cd00a17dd78f10756d71c7eb848')
+md5sums=('SKIP' 'af02374e700522e56cb9bc606bf31731')
pkgver() {
cd $_gitname
@@ -23,5 +25,8 @@ package() {
mkdir -p "${pkgdir}/opt/"
cp -r "$srcdir/$_gitname" "${pkgdir}/opt/couchpotato"
+ # Fix for issues with Python 3
+ find "${pkgdir}/opt/couchpotato" -type f -exec sed -i 's/env python/env python2/g' {} \;
+
install -Dm644 "${srcdir}/couchpotato.service" "${pkgdir}/usr/lib/systemd/system/couchpotato.service"
}