summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrunnytu2017-08-07 21:21:20 +0200
committerrunnytu2017-08-07 21:21:20 +0200
commit06473e545435489fa37c8f223cc36c38ab75ec91 (patch)
treeb7a497b5a1502ac16a88996fc93e283bdd9e0677 /PKGBUILD
parent8ff2872e80a813e99b6fb72eca8fc89436b5b31a (diff)
downloadaur-06473e545435489fa37c8f223cc36c38ab75ec91.tar.gz
Update to 0.68.0-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 28 insertions, 30 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4b582a0d2814..a75275a90667 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
# Old Maintainer: Jonas Heinrich <onny@project-insanity.org>
# Contributor: tobias <tobias@archlinux.org>
# Contributor: Tobias Kieslich <tobias@justdreams.de>
+# Contributor: Neil Romig <neil@sixtythree.me.uk>
pkgname=courier-authlib
pkgver=0.68.0
-pkgrel=1
-pkgdesc="Authentification library for the courier mailserver(s)"
+pkgrel=2
+pkgdesc="Authentication library for the Courier mailserver(s)"
arch=(i686 x86_64)
license=('GPL2')
url="http://courier-mta.org/authlib/"
@@ -20,14 +21,12 @@ optdepends=('sqlite: With support for the authsqlite authentication module'
'libldap: With support for the authldap authentication module'
'postgresql-libs: With support for the authpgsql authentication module'
'pam: With support for the authpam authentication module')
-options=(!libtool)
+options=(!libtool !staticlibs emptydirs)
install=${pkgname}.install
source=(http://downloads.sourceforge.net/project/courier/authlib/${pkgver}/${pkgname}-${pkgver}.tar.bz2
courier-authlib.tmpfiles
authdaemond.service)
-sha512sums=('5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b'
- '6fa87f52a3a26ae470bc28f9ff6d5f7c16afc5ccaf0d3209378e7339271d568dc59ca9fc9d0b5bbfc4155e76702f5de18899237252860a4a3636eabb94a770d7'
- '923b501bd250068956d304c2ab922af4e22f2828eae9fb17dc5945bbd2af3d0eb641ba8783a91a20f970bdda95e97f6ef2801e0b50d767c626ca38de6cb140b4')
+sha512sums=('5c4adaf0fd69f4b9e780962aa3f9eeac6b15cea3f302288ff4549ce2b0be9ea0808b4501670ef3c4e0419c3d27505c256c082f795dea4683dd5265fd7dcab93b' '5047fea9990cd2cd415e11c81fbd8ff83b70dadf0fc178b2398b2c9930843a4669abb3c6801f2953c1ebfdae73c1f82d0ee8c24e900f3876ee6b3aa689363b62' '2168a3d2f92bbc4c24ba80030236dd39a871ccd0f945ea9481518356f6ddfeec3661f161cd6a65d852bce6d9b089d7fa4860337615b9157199aaef336c58d268')
build() {
cd ${srcdir}/${pkgname}-${pkgver}
@@ -38,10 +37,17 @@ build() {
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--with-db=gdbm \
- --with-mailuser=courier --with-mailgroup=courier \
- --with-authpam --with-authpwd --with-authshadow \
- --with-authldap --with-authmysql --with-authpgsql \
- --with-authuserdb --with-authcram --with-authdaemon \
+ --with-mailuser=courier \
+ --with-mailgroup=courier \
+ --with-authpam \
+ --with-authpwd \
+ --with-authshadow \
+ --with-authldap \
+ --with-authmysql \
+ --with-authpgsql \
+ --with-authuserdb \
+ --with-authcram \
+ --with-authdaemon \
--with-authdaemonvar=/run/authdaemon
#--with-authsqlite --with-sqlite-libs
make
@@ -49,33 +55,25 @@ build() {
package() {
cd ${srcdir}/${pkgname}-${pkgver}
+
make DESTDIR=${pkgdir} install
- ###############################################################################
- # post_installation ---- rename the config file and change ownerschip
+
for distfile in ${pkgdir}/etc/authlib/*.dist; do
+ # change ownership - this is usually done by the Makefile where it is assumed the user & group already exist
chown 72:72 ${distfile}
+ # remove the .dist suffix - mimics the install-configure step of a standard Courier installation
mv ${distfile} ${pkgdir}/etc/authlib/`basename ${distfile} .dist`
done
- # copy the .schema; mostly refered to as courier.schema -> rename it
- install -Dm 444 authldap.schema \
- ${pkgdir}/etc/openldap/schema/courier.schema
- ###############################################################################
- #mkdir -p ${pkgdir}/var/spool/authdaemon
- #chown -R 72:72 ${pkgdir}/var/spool/authdaemon
- mkdir -p ${pkgdir}/run/authdaemon
- mkdir -p ${pkgdir}/var/spool/courier
- chown -R 72:72 ${pkgdir}/var/spool/courier
- # docs say we can remove .a files after make
- find ${pkgdir} -name '*\.a' -exec rm -f {} \;
- # Make libs available to /usr/lib
- cd $pkgdir/usr/lib
- for lib in courier-authlib/*.so; do
- ln -s $lib .
- done
+
+ # copy the .schema; mostly refered to as courier.schema -> rename it
+ install -Dm 444 authldap.schema ${pkgdir}/etc/openldap/schema/courier.schema
+
+ chown 72:72 ${pkgdir}/usr/lib/courier-authlib
# Install service file
install -Dm 644 "${srcdir}/authdaemond.service" "${pkgdir}/usr/lib/systemd/system/authdaemond.service"
- # Install systemd configuration files
- install -Dm644 "$srcdir/courier-authlib.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/courier-authlib.conf"
+ # Install systemd configuration file
+ install -Dm 644 "$srcdir/courier-authlib.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/courier-authlib.conf"
}
+