summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorrunnytu2018-09-18 23:06:16 +0200
committerrunnytu2018-09-18 23:06:16 +0200
commit9eb545d8fe47538271ad81a3c7b7cdf791a91d5d (patch)
treea8fe5368f2a25f57aa0d9358eafc518b4f8869bd /PKGBUILD
parent87b1c97ae9165dac27bd6cba131c4c52e1e038d1 (diff)
downloadaur-9eb545d8fe47538271ad81a3c7b7cdf791a91d5d.tar.gz
Update to 5.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 35 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index efe703e87b0c..7ab0e78df771 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# Committer: Manolis Tzanidakis <manolis@archlinux.org>
pkgname=courier-imap
-pkgver=4.18.2
-pkgrel=2
+pkgver=5.0.0
+pkgrel=1
pkgdesc="IMAP(s)/POP3(s) Server"
arch=('i686' 'x86_64' 'armv7h')
license=('GPL2')
url="http://www.courier-mta.org/imap/"
-depends=('courier-maildrop' 'gcc-libs' 'gamin' 'gdbm' 'openssl' 'courier-unicode>=2.0' 'courier-authlib')
+depends=('courier-maildrop' 'gcc-libs' 'gamin' 'gdbm' 'openssl' 'courier-unicode>=2.1' 'courier-authlib>=0.69.0')
backup=('etc/courier-imap/imapd.cnf' 'etc/courier-imap/pop3d.cnf' \
'etc/courier-imap/imapd' 'etc/courier-imap/imapd-ssl' \
'etc/courier-imap/pop3d' 'etc/courier-imap/pop3d-ssl')
@@ -23,12 +23,41 @@ source=(http://downloads.sourceforge.net/project/courier/imap/${pkgver}/${pkgnam
courier-imapd.service
courier-pop3d.service
courier-pop3d-ssl.service)
-sha512sums=('821f0151012f1a357faf705d938d8498a939cc994957398c0d5e2b7a619eabe202549f174e625161545ba6a94b753072458e9f0edc30cbb2443b15405740347e'
+sha512sums=('67cbf69dcf393ed70c26f624a7fcd3702781327ec0a4683314c30a42fd7c3ee4ffdb5c32a69c3e269e2055617fb26290d9a399898997f442dff9996f9eb90224'
'dfb4caa92e5033fbd5396df2e1718ae1f18d63d41f61e14014edee31f823d0fe49a151af570546767a7bafa31e0517717c1aef82896ff6741696a35bba397925'
'7cd18dc9449255ab7fc945ceb836e470afcfa2e722bd20c19d46a88082eee61d9136a4cbccc082625ba1f0c97d70c287d2b98718694613c32a180decce5f3051'
'419014a8956bb82de36f29afe859b6b2b57818fc7456a734c3447b389ff606c2bfe400506a2c33d4cec005583081e4cb78c38230d126aadc1f62b9ce0ec1e4d0'
'896af7b284e48f1b85f7d485b3ca169b2b5b90f8678018a1473fe18b4852f149623c2883614d5aa8205f1a3debe910b5cbf18904adb4985bb72059704f9ebec1')
+prepare() {
+while [ "$option" != 2 ]
+do
+echo "**************************************************************************"
+echo "This message is only meant to make sure you've read the instructions in"
+echo "INSTALL file about updating from earlier versions; specifically the need"
+echo "to convert any existing maildirs to a Unicode naming scheme manually using"
+echo "maildirmake, more info in http://www.courier-mta.org/maildirmake.html."
+echo "**************************************************************************"
+echo ""
+echo "Choose an option:"
+echo ""
+echo "1) Install package anyway"
+echo "2) Abort"
+echo ""
+read -rp "Choose an option [1 - 2] " option
+case $option in
+1)
+break;;
+2)
+exit 0;;
+*)
+echo "'$option' I don't recognize this option."
+echo "Press enter to continue..."
+read -r;;
+esac
+done
+}
+
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -48,7 +77,8 @@ build() {
--with-piddir=/run/courier \
--with-trashquota \
--with-db=gdbm \
- --with-mailuser=courier --with-mailgroup=courier
+ --with-mailuser=courier --with-mailgroup=courier \
+ --with-notice=unicode
make
}