summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEric Engestrom2020-01-22 10:59:07 +0000
committerEric Engestrom2020-01-22 11:16:30 +0000
commit26a0072c5003cc4791ce7ed4c261152edfea7d3d (patch)
tree8923c2c81ea3bffc8693073b057afabb49a28954 /PKGBUILD
parent0cc1589ca525494de72f747ad43a9e9b5dd517e9 (diff)
downloadaur-26a0072c5003cc4791ce7ed4c261152edfea7d3d.tar.gz
bump pkgrel again, this time because I didn't test the package before pushing it...
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cb0188e7209..5c7c71adc575 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=cov-analysis
pkgver=2019.03
-pkgrel=2
+pkgrel=3
pkgdesc='Coverity Scan Build Tool for C/C++ - REQUIRES MANUAL DOWNLOAD'
url='https://scan.coverity.com/download'
arch=('i686' 'x86_64')
@@ -23,11 +23,11 @@ package() {
msg2 "Extracting $tar with bsdtar"
install -dm755 "$pkgdir/opt/$pkgname"
cd "$pkgdir/opt/$pkgname"
- bsdtar --strip-components=2 -xf "$srcdir/$tar"
+ bsdtar --strip-components=1 -xf "$srcdir/$tar"
chown root: -R "$pkgdir/opt/$pkgname/"
cd "$srcdir"
install -dm755 "$pkgdir/etc/profile.d"
- sed "s#@PATH@#/opt/$pkgname/#" "$pkgname.sh" > "$pkgdir/etc/profile.d/$pkgname.sh"
- chmod 755 "$pkgdir/etc/profile.d/$pkgname.sh"
+ sed "s#@PATH@#/opt/$pkgname/bin#g" "$pkgname.sh" > "$pkgdir/etc/profile.d/$pkgname.sh"
+ chmod 644 "$pkgdir/etc/profile.d/$pkgname.sh"
}