summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoranthraxx2016-11-12 13:51:04 +0100
committeranthraxx2016-11-12 13:51:04 +0100
commit1b5bb15c18fa561ed7e093910eba28554cfe3793 (patch)
treedbbfba3561238208f0a8863f02ec85254356ff3f /PKGBUILD
parentcb36cf01e4dcab661aada4ac867fa540c666c355 (diff)
downloadaur-1b5bb15c18fa561ed7e093910eba28554cfe3793.tar.gz
upgpkg: cowrie 1.1.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 19 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 09798ad201a9..0365d7154be1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,45 @@
# Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
pkgname=cowrie
-pkgver=1.0.0_alpha
-_pkgver=${pkgver/_/-}
+pkgver=1.1.0
pkgrel=1
-pkgdesc="A medium interaction SSH honeypot designed to log brute force attacks and, most importantly, the entire shell interaction performed by the attacker"
-url="https://github.com/micheloosterhof/cowrie.git"
+pkgdesc='Medium interaction SSH honeypot designed to log brute force attacks and entire shell interaction'
+url='https://github.com/micheloosterhof/cowrie'
arch=('any')
license=('BSD')
-depends=('twisted' 'pycrypto' 'zope-interface' 'python2-pyasn1')
+depends=('twisted' 'zope-interface' 'zope-interface' 'python2-crypto' 'python2-pyasn1' 'python2-cryptography'
+ 'python2-gmpy2' 'python2-pyopenssl' 'mysql-python' 'python2-dateutil' 'python2-tftpy')
backup=('etc/cowrie.cfg')
install=cowrie.install
-source=(${pkgname}-${pkgver}.tar.gz::https://github.com/micheloosterhof/${pkgname}/archive/v${_pkgver}.tar.gz
- cowrie.service
- INSTALL)
-sha512sums=('0ffcb55906d30869f551676fbdded32d5de50519107f9e1e2be27c8a8914b887af4070c470abee5018b1edb815c604b1961a5598ab1d9b61764034bcf191995b'
- '106618a2c73d5f1f2ad75997e693f6ff4e903644a6be0dc59e85f72ae81f583927b2f079823c3379a8796e03fd542f497d2cc9405dc5d0d20d6caeb9dc88abed'
- 'a80dc0e9ec922c795af13ec85fc4e3414481a0d7ae14d9f17e29ade2a118010c1d69d474fe38c7e648d69b07ff09144efe97183e8a64ccf8165ec3a767a18ce2')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/micheloosterhof/${pkgname}/archive/v${pkgver}.tar.gz)
+sha512sums=('da6cb2e25f57dd5a1e9b7ff02a39ae4d6955ee2be03b0054f92f07b429a1a12b938c571862b05d5ccbe9949d132185079bd93644bd38469e841cb9a8cc95dfbd')
prepare() {
- cd ${pkgname}-${_pkgver}
- sed -e 's|env python$|env python2|g' -i utils/*.py
- sed -e 's|/usr/bin/python$|/usr/bin/python2|g' -i utils/fsctl.py
+ cd ${pkgname}-${pkgver}
+ sed -e 's|env python$|env python2|g' -i bin/* cowrie/commands/tftp.py
+ sed -e 's|/home/cowrie|/opt|g' -i doc/systemd/cowrie.service
+ sed -e '/PIDFile/d' -i doc/systemd/cowrie.service
+ sed -r 's|(cowrie)$|\1 -c /etc/cowrie.cfg|g' -i start.sh
}
build() {
- cd ${pkgname}-${_pkgver}
+ cd ${pkgname}-${pkgver}
python2 -m compileall .
python2 -O -m compileall .
}
package() {
- cd ${pkgname}-${_pkgver}
+ cd ${pkgname}-${pkgver}
install -Dm 644 cowrie.cfg.dist "${pkgdir}/etc/cowrie.cfg"
- install -Dm 644 "${srcdir}/cowrie.service" "${pkgdir}/usr/lib/systemd/system/cowrie.service"
+ install -Dm 644 doc/systemd/cowrie.service -t "${pkgdir}/usr/lib/systemd/system"
- find . -type f -not \( -name cowrie.cfg.dist -o -name start.sh -o -name stop.sh \
- -o -name '.git*' -o -path './.git/*' \) \
- -exec install -Dm 644 {} "${pkgdir}/opt/cowrie/{}" \;
+ install -d "${pkgdir}/opt/cowrie"
+ cp -a . "${pkgdir}/opt/cowrie"
+ rm -r "${pkgdir}/opt/cowrie/cowrie.cfg.dist"
install -Dm 644 doc/COPYRIGHT "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm 644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README"
- install -Dm 644 "${srcdir}/INSTALL" "${pkgdir}/usr/share/doc/${pkgname}/INSTALL"
+ install -Dm 644 README.md INSTALL.md CHANGELOG.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}
# vim: ts=2 sw=2 et: