summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTobias Hunger2019-09-26 21:41:02 +0200
committerTobias Hunger2019-09-26 21:41:02 +0200
commit9bb8d0ab2895d9c80319c9f07bab9bdec410c9a0 (patch)
treefeffaf41973334da763caa621c60da373c088512 /PKGBUILD
parent0f99fe48242d9debdc95c7d42264b9f6c1d90817 (diff)
downloadaur-9bb8d0ab2895d9c80319c9f07bab9bdec410c9a0.tar.gz
Update to new coz from git
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 8 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 841fb50186b3..fb14de341722 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Jon Gjengset <jon@thesquareplanet.com>
pkgname=coz-git
-pkgver=r258.11e868e
+pkgver=r391.72c4afe
pkgrel=1
pkgdesc="a new kind of profiler that measures optimization potential"
arch=('x86_64')
url="https://github.com/plasma-umass/coz"
license=('BSD')
-depends=('python' 'clang>=3.1')
-makedepends=('git')
+depends=('python3' 'libelfin-git' 'npm')
+makedepends=('git' 'python-docutils')
options=()
install=
source=('coz-git::git+https://github.com/plasma-umass/coz.git')
@@ -24,16 +24,14 @@ prepare() {
build() {
cd "$srcdir/$pkgname"
- make -C libcoz
+ make
}
package() {
- cd "$srcdir/$pkgname"
- install -Dm755 "$srcdir/$pkgname/coz" "$pkgdir/usr/share/coz/coz"
- install -d "$pkgdir/usr/bin"
- ln -sfn "/usr/share/coz/coz" "$pkgdir/usr/bin"
- install -Dm644 "$srcdir/$pkgname/libcoz/libcoz.so" "$pkgdir/usr/share/coz/libcoz/libcoz.so"
- install -Dm644 "$srcdir/$pkgname/include/coz.h" "$pkgdir/usr/include/coz.h"
+ cd $pkgname
+
+ mkdir -p "$pkgdir/usr/share/man/man1"
+ make prefix="$pkgdir/usr" install
}
# vim:set ts=2 sw=2 et: