summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJon Gjengset2015-10-06 17:22:19 -0400
committerJon Gjengset2015-10-06 17:26:13 -0400
commitdc33e63b8b60f57267cb30b14cf1b6348c4e8c7f (patch)
treea8c12c6abf3fef0747d76e9438702004a263ab17 /PKGBUILD
parentdfb586074508f9b505bcfb8909ff6dde8f066746 (diff)
downloadaur-dc33e63b8b60f57267cb30b14cf1b6348c4e8c7f.tar.gz
Add patches needed to get coz running on Arch.
Submitted upstream as PRs in: - https://github.com/plasma-umass/coz/pull/24 - https://github.com/plasma-umass/coz/pull/23 - https://github.com/plasma-umass/coz/pull/22
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 13 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 676f29e4f5b2..76f0859517b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,14 +10,25 @@ depends=('python' 'clang>=3.1')
makedepends=('git')
options=()
install=
-source=('coz-git::git+https://github.com/plasma-umass/coz.git')
-md5sums=('SKIP')
+source=('coz-git::git+https://github.com/plasma-umass/coz.git'
+ 'python2.patch' 'no-force-preload.patch' 'tput.patch')
+md5sums=('SKIP'
+ 'f3ff4dcc098eb00e949b362594918517'
+ 'b7926ac1504babe0b2551983d2d5ed25'
+ 'e14ecdc19cbf244388d6af0a55046083')
pkgver() {
cd "$srcdir/$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$pkgname"
+ patch -Np1 < "$srcdir/python2.patch"
+ patch -Np1 < "$srcdir/no-force-preload.patch"
+ patch -Np1 < "$srcdir/tput.patch"
+}
+
build() {
cd "$srcdir/$pkgname"
make