summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBart Libert2022-07-15 10:42:37 +0200
committerBart Libert2022-07-15 10:42:37 +0200
commit002889b0bd6c58d74a87887446f3ed31fe1bf7dc (patch)
tree10e01bae99230f02eb4be0c70b8c65697e9e83e7 /PKGBUILD
downloadaur-002889b0bd6c58d74a87887446f3ed31fe1bf7dc.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..793cbf4e546b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Bart Libert <aur@bart.libert.email>
+pkgname=cp-p-git
+pkgver=r17.daf5066
+pkgrel=1
+pkgdesc="cp (and mv), with progress"
+arch=('any')
+url="https://github.com/Naheel-Azawy/cp-p"
+license=('GPL3')
+makedepends=('git')
+provides=(${pkgname%-git})
+source=("${pkgname%-git}::git+https://github.com/Naheel-Azawy/cp-p.git")
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}