summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornroi2017-01-01 17:11:22 +0100
committernroi2017-01-01 17:11:22 +0100
commitcd9dfc74f135115a61b21d5ca190b509fa2edb0d (patch)
treed8384e28088c7fbe800b688e6a325cafc2cfa4a1 /PKGBUILD
parente732a63bec32d321068ae2ab8df1a5cb018159eb (diff)
downloadaur-cd9dfc74f135115a61b21d5ca190b509fa2edb0d.tar.gz
Update to changes from upstream
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a38c4aec16e6..4e29373d82e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: nroi <nroi@mailbox.org>
pkgname=cpcache-git
-pkgver=r88.6e0a8cc
+pkgver=r95.974c568
pkgrel=1
pkgdesc="central pacman cache"
arch=('i686' 'x86_64' 'armv7h' 'aarch64')
@@ -14,11 +14,13 @@ source=('git+https://github.com/nroi/cpcache.git'
'sysuser.conf'
'cpcache.install'
'cpcache.service'
+ 'create_db.sh'
)
sha256sums=('SKIP'
'0098e749b19617c0f7d619d47a3bc3015bab62e9ad0916087502daff672fb309'
- 'e326c1097269a47a35fe327d839a566d90888339f7cc00b2207e0accf441e6cd'
+ 'effdcc6de465d342f4aba039c853d48e501cf0e55ed4f896cf638ba3499584f6'
'0523a85ce955f9a221340a2bcd8b3f2543dc817469e36623db06630bea925918'
+ '42c01be8766d2b48f142a7b848d5708035b80143af8f0bb02e69a3bc7fff3825'
)
pkgver() {
@@ -27,11 +29,12 @@ pkgver() {
}
package() {
+ mkdir -p "${pkgdir}/var/cache/cpcache/mnesia"
+ ./create_db.sh "${pkgdir}"
cd "${srcdir}/${pkgname%-git}"
/usr/bin/mix local.hex --force
/usr/bin/mix local.rebar --force
/usr/bin/mix deps.get
- /usr/bin/mix release.init
MIX_ENV=prod /usr/bin/mix release --env=prod
mkdir -p "${pkgdir}/usr/share/${pkgname%-git}"
mkdir -p "${pkgdir}/var/lib/${pkgname%-git}"