summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2020-02-22 22:39:51 -0500
committerTony Lambiris2020-02-22 22:39:51 -0500
commit94aa81fcf95914642fcc22e231dc18d1d33ff6c0 (patch)
treec78926addba8f21a37b5cf205373cbd0c2482d8c /PKGBUILD
parent6db7e4636930c7359148237620787381beaa9f74 (diff)
downloadaur-94aa81fcf95914642fcc22e231dc18d1d33ff6c0.tar.gz
Version bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 13 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 37a4e733067e..1e5f4b914af3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,30 @@
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
-# Contributor: Andreas W. Hauser <andy-aur@splashground.de>
+# Maintainer: Tony Lambiris <tony@libpcap.net>
+
pkgname=cpdup
-pkgver=1.18
+pkgver=1.20
pkgrel=1
-pkgdesc="DragonFly BSD tool to mirror filesystems retaining permissions, flags, ownership, and utimes"
-url="http://apollo.backplane.com/FreeBSDPorts/"
+pkgdesc="Tool to mirror filesystems retaining permissions, flags, ownership, and utimes"
+url="https://github.com/DragonFlyBSD/cpdup"
license=('BSD')
arch=('i686' 'x86_64')
depends=('libbsd')
makedepends=('pkg-config')
-source=(http://apollo.backplane.com/FreeBSDPorts/cpdup-$pkgver.tar.gz
- GNUmakefile)
-sha256sums=('2bc7ac20a84ae229a1133e0501b41b0065217dff4da1d2a89948d2c696568526'
- 'ff2ce54d0f9d77ee2e49ec18cd88c031a2a650e75422ceb491eed381eeca6a0c')
+source=(https://github.com/DragonFlyBSD/cpdup/archive/v${pkgver}.tar.gz)
+sha256sums=('b8b3edb51c8f57e16f37bb6e4261214af2fdab4e7a13067dd5d47d46f55b1c93')
prepare() {
- cd "$pkgname"
+ cd "${pkgname}-${pkgver}"
# HACK I can't use -D since __unused is used as variable name in some system headers
sed -i 's/__unused/__attribute__((__unused__))/' *.c
}
build() {
- cd "$pkgname"
- make -f "$srcdir"/GNUmakefile
+ cd "${pkgname}-${pkgver}"
+ make
}
package() {
- cd "$pkgname"
- install -Dm 755 cpdup "$pkgdir"/usr/bin/cpdup
- install -Dm 644 cpdup.1 "$pkgdir"/usr/share/man/man1
+ cd "${pkgname}-${pkgver}"
+ make PREFIX="${pkgdir}/usr" install
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}