summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYigit Dallilar2019-12-27 19:28:37 +0100
committerYigit Dallilar2019-12-27 19:28:37 +0100
commit419f7d5660457eba9ddd228d6079bddf6bc032ba (patch)
tree57e6a6bc274f67b13b8ffed9de3ebe3d6bd19b12 /PKGBUILD
downloadaur-419f7d5660457eba9ddd228d6079bddf6bc032ba.tar.gz
7.1.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36b6f956a6d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Yigit Dallilar <yigit.dallilar@gmail.com>
+# Set it to compile with openblas-lapack
+
+pkgname=cpl
+pkgver=7.1.2
+pkgrel=1
+pkgdesc="ESO Common Pipeline Library"
+url="https://www.eso.org/sci/software/cpl/index.html"
+arch=('x86_64')
+license=('GPL2')
+depends=('fftw' 'wcslib' 'cfitsio')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+source=(ftp://ftp.eso.org/pub/dfs/pipelines/libraries/cpl/cpl-7.1.2.tar.gz)
+sha256sums=('b6d20752420e2333e86d9a08c24a08057351a9fef97c32f5894e63fbfece463a')
+
+
+build() {
+
+
+ cd $srcdir/${pkgname}-${pkgver}
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+
+ cd $srcdir/${pkgname}-${pkgver}
+ make DESTDIR="$pkgdir" install
+
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+}
+