summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaximilian Stahlberg2019-04-13 13:29:02 +0200
committerMaximilian Stahlberg2019-04-13 13:46:29 +0200
commit275fb7088a2f698b457d29f68bbc39e54370bf34 (patch)
treeb99e6e5a525cbbc0c12c034a1504b33be16091cc /PKGBUILD
parent626ebc919ff776480493ac4c3cb4bd1f070e464f (diff)
downloadaur-275fb7088a2f698b457d29f68bbc39e54370bf34.tar.gz
Update to 12.9.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4d73119faddd..e0fd9f5cdb82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname='cplex'
pkgdesc="A commercial solver for mathematical optimization problems."
-pkgver=12.8
+pkgver=12.9
pkgrel=2
arch=('x86_64')
url='https://www.ibm.com/software/products/de/ibmilogcpleoptistud'
@@ -24,7 +24,7 @@ _installer="${_basename}.bin"
_archdir="${arch/_/-}_linux"
_python_min_version=$(python --version | awk '{ print $2 }' | awk -F "." '{ print $2 }')
-source=("file://${_installer}" installer.properties.template)
+source=("local://${_installer}" installer.properties.template)
prepare() {
chmod +x "${_installer}"
@@ -86,16 +86,9 @@ package() {
cd "../../../../"
# Install Python bindings.
- if [[ "${_python_min_version}" > 6 ]]; then
- echo -ne "\033[0;31m\033[1mWARNING\033[0m "
- echo "Skipping the installation of Python bindings."
- echo "CPLEX 12.8.0 only supports Python 3.5 and 3.6; later versions of Python are not supported."
- echo "Downgrade to Python 3.6 if you need Python bindings."
- else
- cd "./cplex/python/3.7/${_archdir}/"
- python3 setup.py install --root="${pkgdir}/" --optimize=1
- cd "../../../../"
- fi
+ cd "./cplex/python/3.7/${_archdir}/"
+ python3 setup.py install --root="${pkgdir}/" --optimize=1
+ cd "../../../../"
# Install license.
install -dm755 "${pkgdir}/usr/share/licenses/cplex"
@@ -109,5 +102,5 @@ package() {
chmod -R 644 "${pkgdir}/usr/share/doc/cplex"
}
-md5sums=('1cb4b29131433491a95efd73b145b821'
+md5sums=('7d6523476edd4a245d28d6f095739497'
'f295f6c4ecd0f3a6d2fdca21788efd0f')