summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Hilgenberg2022-11-19 15:30:31 +0100
committerTorsten Hilgenberg2022-11-19 15:30:31 +0100
commit2afa8ffa910700456bbfb6aa10ea53e6a37d678c (patch)
treebd00a85a0516c723b0736df7605ec1ba74e586ba /PKGBUILD
downloadaur-cplot.tar.gz
release 2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a11e4634a4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Torsten Hilgenberg <th@zoon.cc>
+
+pkgname=cplot
+pkgver=2.0
+pkgrel=1
+pkgdesc='Function plotter for real and complex mathematical functions'
+url='https://zoon.cc/cplot/'
+license=('MIT')
+arch=('x86_64')
+
+depends=('zlib' 'sdl2' 'libgl' 'glu' 'glew' 'glibc' 'pango' 'cairo')
+makedepends=('git' 'python>=3.0.0' 'ninja' 'boost')
+source=('git+https://github.com/hilgenberg/cplot#commit=a8b8f5f6ad42698c36cc55710a616c304aa56bb5')
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/cplot/"
+ git submodule update --init --recursive --depth 1
+}
+
+build() {
+ cd "$srcdir/cplot/"
+ ./build release
+}
+
+package() {
+ cd "$srcdir/cplot/"
+ install -Dm755 -t "$pkgdir/usr/bin/" build_release/cplot
+ install -Dm644 -t "$pkgdir/usr/share/cplot/" Plot\ Examples/*.cplot
+ install -Dm644 -t "$pkgdir/usr/share/licenses/cplot/" LICENSE
+}