summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsum012020-08-08 11:35:58 -0400
committersum012020-08-08 11:35:58 -0400
commit0924a41abe748fb35f2487f4956f80e1411a7712 (patch)
treec6ff759b310f8744be3001480bf5dce0b5cbb11d /PKGBUILD
parentef83ce04871d12374776036cd68d4eb29c508f0c (diff)
downloadaur-0924a41abe748fb35f2487f4956f80e1411a7712.tar.gz
v0.7.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8fd4c4cfc5d..72931f03a3cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=cpp-httplib
-pkgver=0.7.3
+pkgver=0.7.4
pkgrel=1
pkgdesc='A C++ header-only HTTP/HTTPS server and client library'
arch=('any')
@@ -9,11 +9,11 @@ license=('MIT')
makedepends=('cmake>=3.14')
optdepends=('openssl>=1.1.1: HTTPS support' 'zlib: compression support' 'brotli: Brotli decompression support')
source=("$pkgname-$pkgver.tar.gz::https://github.com/yhirose/cpp-httplib/archive/v$pkgver.tar.gz")
-sha512sums=('b25d6ed36ef4ced678f35ea606c960faeeec3b66880c4bd0e48978bfdaebdd923a6d3b4f28106bee2bb13c1eb04a8a23f06886a23b96b600b963fbe5fba011ea')
+sha512sums=('7fe64da5265df26f3d9c4d301755bd5041b612e4814a7a74078faf5580c27e7b13f8a684eef8d61b8b012c718979ae995e3afbe17fcbc2fba1f469894f1dcd73')
build() {
cd "$srcdir/$pkgname-$pkgver"
# Lets us force a full version string to be defined instead of just a major.minor
- sed -i "82s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
+ sed -i "86s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
mkdir -p "build"
cd "build"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..