summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsum012020-07-28 23:11:49 -0400
committersum012020-07-28 23:11:49 -0400
commit343a4cc8934e2fe493575e542a51af6daaed3d18 (patch)
treeaba210155624446d695d118f04b24c26f4d7c60b /PKGBUILD
parent47121a592fe6ae5c11b3c942ad752ba1a3618d34 (diff)
downloadaur-343a4cc8934e2fe493575e542a51af6daaed3d18.tar.gz
v0.7.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 33edc1afb8f7..3af4a0936776 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=cpp-httplib
-pkgver=0.7.1
+pkgver=0.7.2
pkgrel=1
pkgdesc='A C++ header-only HTTP/HTTPS server and client library'
arch=('any')
url='https://github.com/yhirose/cpp-httplib'
license=('MIT')
makedepends=('cmake>=3.14')
-optdepends=('openssl>=1.1.1: https support' 'zlib: compression support')
+optdepends=('openssl>=1.1.1: HTTPS support' 'zlib: compression support' 'brotli: Brotli decompression support')
source=("$pkgname-$pkgver.tar.gz::https://github.com/yhirose/cpp-httplib/archive/v$pkgver.tar.gz")
-sha512sums=('634690ca0289026d2ea15075ee7b5691a28f0028a015ba5c19994c2680bad9ee955858f621032d2d6ef7d1a334c13a9f640b0a4c24bb5f8725a040c372bf2fb3')
+sha512sums=('2b92e2f7bde485c4b01ee45055a4982c462175221b00e19fbc9230df24f390d82596d7a1e288a69dc0201d5a08603f7bb2494034e83f294115e55b907e895125')
build() {
cd "$srcdir/$pkgname-$pkgver"
# Lets us force a full version string to be defined instead of just a major.minor
- sed -i "76s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
+ sed -i "82s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
mkdir -p "build"
cd "build"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..