summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsum012021-07-16 00:15:35 -0400
committersum012021-07-16 00:15:35 -0400
commit991038d3a33e2e94819f01a029f18dad5f8878c2 (patch)
tree19c3c8ec6682f4c49d3bb27614bf12d4ade9dd90 /PKGBUILD
parent14727883621a61a9a873de88bab8f99e7c230507 (diff)
downloadaur-991038d3a33e2e94819f01a029f18dad5f8878c2.tar.gz
v0.9.1
Also quiet the "no git tag" warning by deleting that line. It isn't important if you're curious, just a holdover from manually inserting the full version versus the MAJOR.MINOR that the Cmake generates.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 725afb8b1a3e..59615f5c31cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=cpp-httplib
-pkgver=0.9.0
+pkgver=0.9.1
pkgrel=1
pkgdesc='A C++ header-only HTTP/HTTPS server and client library'
arch=('any')
@@ -9,11 +9,13 @@ license=('MIT')
makedepends=('cmake>=3.14')
optdepends=('openssl>=1.1.1: HTTPS support' 'zlib: compression support' 'brotli: Brotli decompression support')
source=("$pkgname-$pkgver.tar.gz::https://github.com/yhirose/cpp-httplib/archive/v$pkgver.tar.gz")
-sha512sums=('09c408103dc1c54aea297f69e6d82f5df73c58e6b377df9bf1f438cf7aa39758ef16df3ffeda62e72014816de978f37a4ab744dbc0460e2dbd0f6d2638eb337a')
+sha512sums=('164812075ad516a0a0ad587d7a479e0272fc5eecdbbf4522532dc3039a5282cc120b5b7d75eea3764d21acf203dc1bfccfb9e4f1dfe2515ca4ced546735c28fc')
build() {
cd "$srcdir/$pkgname-$pkgver"
+ # Quiets the "no git tag" warning
+ sed -i "78d" "CMakeLists.txt"
# Lets us force a full version string to be defined instead of just a major.minor
- sed -i "87s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
+ sed -i "86s/^/set\(_httplib_version ${pkgver}\)/" "CMakeLists.txt"
mkdir -p "build"
cd "build"
cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..