summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorinhzus2020-04-05 18:54:18 +0800
committerinhzus2020-04-05 18:54:18 +0800
commit6f6d468b0e0519c078a51667a855a03566c00d64 (patch)
treec3f54d2fb7808039be91c25cc739c35e87c389de /PKGBUILD
parent46ddf30dce90c9ebfe0c32aed1a166a6f65bef19 (diff)
downloadaur-6f6d468b0e0519c078a51667a855a03566c00d64.tar.gz
cppinsights r553.2607267
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0a4b36c8f883..bd0d6ec18743 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: inhzus <inhzus@gmail.com>
pkgname=cppinsights-git
-pkgver=r548.926ca18
+pkgver=r553.2607267
pkgrel=1
pkgdesc="C++ Insights - See your source code with the eyes of a compiler"
arch=('x86_64')
url="https://cppinsights.io"
license=('MIT')
groups=()
-depends=()
+depends=(clang)
makedepends=('git' 'sed' 'ninja')
provides=("cppinsights")
conflicts=("cppinsights")
@@ -30,6 +30,7 @@ pkgver() {
build() {
cd "$srcdir/${pkgname}"
test -d build || mkdir build
+ sed -i "s/INSIGHTS_MIN_LLVM_MAJOR_VERSION 10/INSIGHTS_MIN_LLVM_MAJOR_VERSION 9/" CMakeLists.txt
cd build
cmake -G"Ninja" ..
sed -i "s/-isystem/-I/g" build.ninja