summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGermán L. Osella Massa2015-10-04 17:27:19 -0300
committerGermán L. Osella Massa2015-10-04 17:27:19 -0300
commitd2e2485a3dc157f852c63d3d9f50b8ae9597e99f (patch)
treef6c5fe2fddd89864ca06959028485ae72e43e3c9 /PKGBUILD
downloadaur-d2e2485a3dc157f852c63d3d9f50b8ae9597e99f.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d91d9979bf39
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Germán Osella Massa <gosella@gmail.com>
+# Based on a previous PKGBUILD available on AURv3.
+# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
+# Contributor: Tianjiao Yin <ytj000@gmail.com>
+# Contributor: Vinicius de Avila Jorge <vinicius.avila.jorge@gmail.com>
+pkgname=cppreference
+pkgver=20150808
+pkgrel=1
+pkgdesc="A complete reference for the features in the C++ Standard Library. HTML book."
+arch=('any')
+url="http://en.cppreference.com/"
+license=('CCPL:cc-by-sa')
+options=('!strip' '!emptydirs')
+depends=('ttf-dejavu')
+source=("http://upload.cppreference.com/mwiki/images/0/01/html_book_${pkgver}.tar.gz")
+sha256sums=('488fa0b360545b09e75f18719050ae21b1e0ba2dee5ed34e4c88e374eeadf78f')
+
+package() {
+ rm "$srcdir/reference/common/DejaVuSansMonoCondensed60.ttf"
+ rm "$srcdir/reference/common/DejaVuSansMonoCondensed75.ttf"
+ mkdir -p "$pkgdir/usr/share/doc/cppreference"
+ mv -t "$pkgdir/usr/share/doc/cppreference/" $srcdir/reference/*
+}