summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2023-05-05 20:24:47 -0400
committeréclairevoyant2023-05-05 20:24:47 -0400
commitd6a69ac685a8a08f9e57e8c4c28e5317e462ee41 (patch)
treef7fea83db5f2a496d52441113fa716255216e652 /PKGBUILD
parent68f6f0bbafdba9dbdf25172c59acff3bb5d6226e (diff)
downloadaur-cpuset.tar.gz
cpuset: upgrade to python 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 18 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb342d58812d..7a32812cbff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,24 @@
-# Maintainer: Jon Gjengset <jon@thesquareplanet.com>, Saren Arterius <saren@wtako.net>
+# Maintainer: éclairevoyant
+
pkgname=cpuset
pkgver=1.6
-pkgrel=1
-pkgdesc="Cpuset is a Python application to make using the cpusets facilities in the Linux kernel easier."
-arch=('any')
-url="https://github.com/lpechacek/cpuset/"
-license=('GPL2')
-depends=('python2' 'python2-future' 'python2-configparser')
+pkgrel=2
+pkgdesc="Python app to make using the cpusets facilities in the Linux kernel easier"
+arch=(any)
+url="https://github.com/lpechacek/$pkgname"
+license=(GPL2)
+depends=(python)
+makedepends=(python-setuptools)
options=('!emptydirs')
-source=("https://github.com/lpechacek/cpuset/archive/v${pkgver}.tar.gz")
-md5sums=('365dcccfef9ac095530821a7e711b308')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+b2sums=('389c274981fe9a23188da71ce0fbc1e0bcdfe6dbe0108bf45659511cbbf711022108914e16aa679c0934f9a5a06b69129738d5f85e96aeb7604cef9c840133a3')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py build
+}
package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
}