summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSidney Crestani2016-12-05 15:52:33 -0200
committerSidney Crestani2016-12-05 15:52:33 -0200
commit7993321bbf9198ecb391d002f4643dc5abfa595b (patch)
tree489102544c675278c9adcff952a3f84b2220d3d2 /PKGBUILD
downloadaur-7993321bbf9198ecb391d002f4643dc5abfa595b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1ea8583d9e76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Sidney Crestani <sidneycrestani@archlinux.net>
+# Base PKGBUILD from ArchStrike
+
+pkgname=creak-git
+pkgver=20161118.r38
+pkgrel=1
+arch=('any')
+pkgdesc="Performs some of the most famous MITM attack on target addresses located in a local network."
+url="https://github.com/codepr/creak"
+license=('GPL3')
+depends=('python2' 'python2-dpkt' 'python2-pypcap' 'scapy' 'libdnet')
+makedepends=('python2-setuptools' 'git')
+provides=('creak')
+conflicts=('creak')
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+ printf "%s.r%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)"
+ }
+
+ prepare() {
+ grep -iRl 'python' ${pkgname} | xargs sed -i 's|python$|python2|g'
+ }
+
+ package() {
+ cd ${pkgname}
+ install -dm755 "${pkgdir}/usr/bin"
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+
+ cp -a --no-preserve=ownership * "${pkgdir}/usr/share/${pkgname}"
+
+ cat > "${pkgdir}/usr/bin/creak" << XXZ
+ #!/usr/bin/env bash
+ cd /usr/share/${pkgname}
+ python2 creak.py "\$@"
+XXZ
+ chmod 755 "${pkgdir}/usr/bin/creak"
+ }
+