summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamuel Littley2018-05-08 20:57:30 +0100
committerSamuel Littley2018-05-08 20:57:30 +0100
commit90df393fc6234018d3de5daf63097c08ca99c079 (patch)
tree807c0970ff0f5cc71878c5d342137ae1b3688ab7 /PKGBUILD
parent561934b8eae0ff2e7ea3f4a44a6b1d654abc6bac (diff)
downloadaur-90df393fc6234018d3de5daf63097c08ca99c079.tar.gz
Update package() per flacks' suggestion
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c08881888a83..a13ca3259c50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: samuellittley <samuel.littley@toastwaffle.com>
pkgname=create-react-native-app
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Bootstrapping tool for React Native"
arch=(any)
url="https://github.com/react-community/create-react-native-app"
@@ -10,5 +10,9 @@ depends=('nodejs')
makedepends=('npm')
package() {
- npm install -g --prefix "$pkgdir/usr" $pkgname@$pkgver
+ cd $srcdir
+ local _npmdir=$pkgdir/usr/lib/node_modules
+ mkdir -p $_npmdir
+ cd $_npmdir
+ npm install -g --prefix $pkgdir/usr $pkgname@$pkgver
}