summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlarchunix2016-06-18 14:52:12 +0200
committerlarchunix2016-06-18 14:52:12 +0200
commit88119c12c535d1fab75b46203112a128c926510c (patch)
treed2cc676ea0d03f1e5e3117abcb753fcec931959f /PKGBUILD
downloadaur-88119c12c535d1fab75b46203112a128c926510c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ea311eb066f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+pkgname=createrepo
+pkgver=0.10.4
+pkgrel=1
+pkgdesc="Create rpm-metadata formatted package repositories"
+arch=('any')
+url="https://github.com/rpm-software-management/$pkgname"
+license=('GPL')
+depends=('deltarpm' 'libxml2' 'python2' 'python2-pyliblzma' 'rpm-org'
+ 'yum' 'yum-metadata-parser')
+makedepends=('bash-completion')
+checkdepends=('pychecker')
+source=("$url/archive/$pkgname-${pkgver//./-}.tar.gz")
+md5sums=('d5a31a4a075010d5c2e51fbf631a368f')
+
+prepare() {
+ mv "$pkgname-$pkgname-${pkgver//./-}" "$pkgname-$pkgver"
+
+ cd "$pkgname-$pkgver"
+ find -type f | xargs sed -e 's|#! */usr/bin/python|&2|' -i
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ make PYTHON=python2
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ make check
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PYTHON=python2 DESTDIR="$pkgdir/" install
+}
+
+# vim: set ft=sh ts=4 sw=4 noet: