summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuint Guvernator2015-07-13 11:51:43 -0400
committerQuint Guvernator2015-07-13 11:51:43 -0400
commit191f955d14f202080726660ecdf6b01c9ab5d3b5 (patch)
treed5c097ddf48e25971d6954056ddb52f32c0b27ab /PKGBUILD
downloadaur-191f955d14f202080726660ecdf6b01c9ab5d3b5.tar.gz
initial upload
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a0c01e308f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Quint Guvernator <quint@guvernator.net>
+
+pkgname="creddit-git"
+pkgver=r177.accd51f
+pkgrel=1
+pkgdesc='CLI Reddit client written in C.'
+arch=('x86_64' 'i686')
+url='https://github.com/Cotix/cReddit'
+license=('MIT')
+depends=('ncurses' 'curl')
+makedepends=('git' 'make' 'gcc')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname::git+http://github.com/Cotix/cReddit.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make PREFIX="$pkgdir/usr/" install
+}