summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorQuint Guvernator2018-06-09 10:24:03 -0400
committerQuint Guvernator2018-06-09 10:24:03 -0400
commitce436a8e79d6b49ad174d545a340848f3b66e7fe (patch)
tree9d181878765be2eb10eb0a7d489bed6b7cec11ac /PKGBUILD
parent191f955d14f202080726660ecdf6b01c9ab5d3b5 (diff)
downloadaur-ce436a8e79d6b49ad174d545a340848f3b66e7fe.tar.gz
add fix for upstream preference for non-default ncursesw
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a0c01e308f7..055a9b9ae8e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Quint Guvernator <quint@guvernator.net>
pkgname="creddit-git"
-pkgver=r177.accd51f
+pkgver=r213.1a45df6f8291
pkgrel=1
pkgdesc='CLI Reddit client written in C.'
arch=('x86_64' 'i686')
@@ -14,6 +14,11 @@ conflicts=("$pkgname")
source=("$pkgname::git+http://github.com/Cotix/cReddit.git")
md5sums=('SKIP')
+prepare() {
+ # patch the location of the ncursesw library
+ patch -p1 -i '../01-ncursesw-is-default-ncurses.patch'
+}
+
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"