summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Picht2020-01-06 08:17:29 +0000
committerMichael Picht2020-01-06 08:17:29 +0000
commit223059483ba678fa7a1418e252cd58f1cf39f47a (patch)
treeb5d4afb892949644fe64cfa06436bee261a9a533 /PKGBUILD
parent8e0e63862f22add2195d43e0073be445c99ec225 (diff)
downloadaur-223059483ba678fa7a1418e252cd58f1cf39f47a.tar.gz
crema-git PKGBUID: changed pkgver()
Signed-off-by: Michael Picht <mipi@fsfe.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1547cb4e4a98..1d822f79241b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -45,8 +45,8 @@ optdepends+=(
)
pkgver() {
- cd "$srcdir/$_pkgname"
- printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/; s/-/./g'
}
build() {