summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Picht2020-04-16 06:03:52 +0000
committerMichael Picht2020-04-16 06:03:52 +0000
commitd203d0ac8108e085e06dd45af261dc581df78d9e (patch)
treec90736c8af8f226883381761d5fd527bcfdfe6c4 /PKGBUILD
parent721f1585c6f988c6442e0858785dacc48adf02a3 (diff)
downloadaur-d203d0ac8108e085e06dd45af261dc581df78d9e.tar.gz
corrected date of 2.2.0
Signed-off-by: Michael Picht <mipi@fsfe.org>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 18 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bca1872c3e0..3d7cc681ca99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,8 @@
# Maintainer: Michael Picht <mipi@fsfe.org>
+#
+# SPDX-FileCopyrightText: 2018-2020 Michael Picht <mipi@fsfe.org>
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
_pkgorg=gitlab.com/mipimipi
pkgname=crema-git
@@ -15,35 +19,33 @@ md5sums=(SKIP)
depends=(
binutils
devtools
+ git
+ pacman
rsync
sudo
)
makedepends=(
git
+ go
make
pandoc
)
optdepends=(gnupg)
provides=(crema)
-conflicts=(crema)
+conflicts=(crema-git)
-# aurutils
-conflicts+=(
- aurutils
- aurutils-git
-)
depends+=(
- jq
- pacutils
- parallel
- wget
-)
-makedepends+=(m4)
-optdepends+=(
- "bash-completion: bash completion"
- "devtools: aur-chroot"
- "vifm: build file interaction"
+# jq
+# pacutils
+# parallel
+# wget
)
+#makedepends+=(m4)
+#optdepends+=(
+# "bash-completion: bash completion"
+# "devtools: aur-chroot"
+# "vifm: build file interaction"
+#)
pkgver() {
cd "$srcdir/$_pkgname"
@@ -53,17 +55,9 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
make
-
- # aurutils
- cd aurutils
- make DESTDIR="$pkgdir"
}
package() {
cd "$srcdir/$_pkgname"
make DESTDIR="$pkgdir" install
-
- # aurutils
- cd aurutils
- make DESTDIR="$pkgdir" install
}